Users browsing this thread: 1 Guest(s)
FFVI: Divergent Paths

Posts: 384
Threads: 38
Thanks Received: 156
Thanks Given: 97
Joined: Feb 2017
Reputation: 23
Status
None
I think I may have found the problem. You said that you first noticed this after Leo spoke to Lola. When you recruited Leo, did you have:
1. 4 members in your party
2. One of them Mog
3. But not Shadow, Gau, or Gogo?

In that specific set of circumstances, a typo would activate in the event script that, instead of checking for 4 characters in the party, would check for character #4 (Shadow). If he was not in your party, The script would force out the actor with the highest character ID, which, in absence of Gau ($0B) or Gogo ($0C), would be Mog ($0A). however, it wouldn't properly dispose of his object, and if he were supposed to be displayed as the main character, would keep him in the last pose he was in during the event scene (facing downward). Reloading the game from a save file would refresh all of the objects correctly, fixing the issue.

I will fix this in the next patch. It is seen as a low priority for now.


Projects:
Divergent Paths: The 3 Scenarios (Completed) - a redo of the 3 scenarios in the original game that gives equal time to each group. Meant to be a basis for future mods.
FFVI: Divergent Paths (In Progress) - a hack built off of the 3 scenarios that changes other events in the same, such as making Leo permanently recruitable, bringing Banon's story closure, and adding 1 more secret character.
  Find
Quote  

Posts: 131
Threads: 12
Thanks Received: 0
Thanks Given: 13
Joined: Oct 2013
Reputation: 0
Status
None
(01-07-2021, 10:17 PM)PowerPanda Wrote: I think I may have found the problem. You said that you first noticed this after Leo spoke to Lola. When you recruited Leo, did you have:
1. 4 members in your party
2. One of them Mog
3. But not Shadow, Gau, or Gogo?

1 and 3. But I should mention, the order I did things was: Recruited Leo, recruited Mog, fought Tritoch, fought and recruited Umaro, then I did the event with Lola cuz I forgot to do so until then. All these events I had a full party of 4, with the last 3 events having Mog in the party. None of these parties had Shadow, Gau, or Gogo. So I have the feeling it was one of the last 3 events I mentioned, so I feel like it's a problem with either Umaro's recruitment event, or the event with Lola.


If you ever feel useless, just remember that Umaro has an MP stat.
  Find
Quote  

Posts: 384
Threads: 38
Thanks Received: 156
Thanks Given: 97
Joined: Feb 2017
Reputation: 23
Status
None
Huh. I've gone over the Umaro recruitment event, and I can't find any oddities. The Lola event is unchanged, save for checking for Leo instead of Cyan in all relevant spots. I'll check again tomorrow.

For tonight's victory, I fixed the bug with Gau's Father's scene, where it would freeze after Gau learned Fight. The details are too in the weeds for me to go into here though.

I'm hard at work on the Ancient Castle sequence, and have the text rewritten with added event triggers that won't allow you into the caslte unless you have both Leo and Terra in your party.


Projects:
Divergent Paths: The 3 Scenarios (Completed) - a redo of the 3 scenarios in the original game that gives equal time to each group. Meant to be a basis for future mods.
FFVI: Divergent Paths (In Progress) - a hack built off of the 3 scenarios that changes other events in the same, such as making Leo permanently recruitable, bringing Banon's story closure, and adding 1 more secret character.
  Find
Quote  

Posts: 6
Threads: 0
Thanks Received: 0
Thanks Given: 0
Joined: May 2019
Reputation: 0
Status
None
Having a little trouble. I applied the patch with Lunar, but depending on which FF6 rom I use, it either plays a chiming sound over and over again and never starts or a bunch of random colors appear and never starts.

I'm at a loss. Never had this issue before. It may be something I'm doing wrong, but I don't know what. Does the SNES emulator need to be a specific one? The ROM a specific version? Any help would be appreciated.

EDIT: NEVERMIND, I solved it with a utility.
  Find
Quote  

Posts: 1
Threads: 0
Thanks Received: 0
Thanks Given: 0
Joined: Jan 2021
Reputation: 0
Status
None
(01-12-2021, 12:29 AM)nobodyimp Wrote: Having a little trouble. I applied the patch with Lunar, but depending on which FF6 rom I use, it either plays a chiming sound over and over again and never starts or a bunch of random colors appear and never starts.

I'm at a loss. Never had this issue before. It may be something I'm doing wrong, but I don't know what. Does the SNES emulator need to be a specific one? The ROM a specific version? Any help would be appreciated.

EDIT: NEVERMIND, I solved it with a utility.

Hey, could you tell me how you did it? I'm having the same trouble here!
  Find
Quote  

Posts: 6
Threads: 0
Thanks Received: 0
Thanks Given: 0
Joined: May 2019
Reputation: 0
Status
None
(01-13-2021, 10:58 PM)Luck_98 Wrote:
(01-12-2021, 12:29 AM)nobodyimp Wrote: Having a little trouble. I applied the patch with Lunar, but depending on which FF6 rom I use, it either plays a chiming sound over and over again and never starts or a bunch of random colors appear and never starts.

I'm at a loss. Never had this issue before. It may be something I'm doing wrong, but I don't know what. Does the SNES emulator need to be a specific one? The ROM a specific version? Any help would be appreciated.

EDIT: NEVERMIND, I solved it with a utility.

Hey, could you tell me how you did it? I'm having the same trouble here!

Sure. I used snesROMutil. It will patch it and create a new file with the patch working.

Lunar IPS and some online tool I tried didn't work. I don't know why.

(01-04-2021, 07:53 PM)rhonryderz Wrote:
(01-04-2021, 01:45 PM)Fast Moon Wrote: rhonryderz@I had this happen to me and I think it was because my headered ROM was 1.1 and not 1.0.  All of the ROMs explicitly marked 1.0 were unheadered that I could find and all the headered ones didn't specify version, so I ended up just pasting the first 200 bytes of the 1.1 header on to the unheadered 1.0 and that fixed the crashing in the first battle issue.  I haven't gone any farther than that so far.

 You mean the Final fantasy 3 rom itself? I tried patched the ff3 rom 1.0 but when I played it, the game crash.  Sad

I am having the same problem. I can't enter a fight sequence without the screen going black.
  Find
Quote  

Posts: 2
Threads: 0
Thanks Received: 0
Thanks Given: 0
Joined: Jan 2021
Reputation: 0
Status
None
I had that same bug with the Mog sprite happen to me shortly after I recruited him (between the Magitek Research Facility and the Cave to the Sealed Gate) but his sprite returned to normal after the Floating Continent became airborne in the WoB. Happened when I placed him at the lead of my party.
  Find
Quote  

Posts: 384
Threads: 38
Thanks Received: 156
Thanks Given: 97
Joined: Feb 2017
Reputation: 23
Status
None
Huh. I wonder if it's something to do with the "Choose a Scenario, Kupo1" setion, and it affects Mog when you recruit him, but there are various points in the game that reset it correctly. The Mog that you get for the "Choose a Scenario, Kupo!" screen in the base game is actually written to Umaro's slot ($0D) in the vanilla game. It's fine in the base game because Umaro isn't accessible till the World of Ruin. Since I have Leo in slot $0D, I had to switch all of the scenario interludes to slot $0A, which is Mog's normal slot. I will look into that.


Projects:
Divergent Paths: The 3 Scenarios (Completed) - a redo of the 3 scenarios in the original game that gives equal time to each group. Meant to be a basis for future mods.
FFVI: Divergent Paths (In Progress) - a hack built off of the 3 scenarios that changes other events in the same, such as making Leo permanently recruitable, bringing Banon's story closure, and adding 1 more secret character.
  Find
Quote  



Forum Jump:

Users browsing this thread: 1 Guest(s)


Theme by Madsiur2017Custom Graphics by JamesWhite