Users browsing this thread: 2 Guest(s)
FFVI: Divergent Paths

Posts: 383
Threads: 38
Thanks Received: 156
Thanks Given: 97
Joined: Feb 2017
Reputation: 23
Status
None
I think I may have found the problem. You said that you first noticed this after Leo spoke to Lola. When you recruited Leo, did you have:
1. 4 members in your party
2. One of them Mog
3. But not Shadow, Gau, or Gogo?

In that specific set of circumstances, a typo would activate in the event script that, instead of checking for 4 characters in the party, would check for character #4 (Shadow). If he was not in your party, The script would force out the actor with the highest character ID, which, in absence of Gau ($0B) or Gogo ($0C), would be Mog ($0A). however, it wouldn't properly dispose of his object, and if he were supposed to be displayed as the main character, would keep him in the last pose he was in during the event scene (facing downward). Reloading the game from a save file would refresh all of the objects correctly, fixing the issue.

I will fix this in the next patch. It is seen as a low priority for now.


Projects:
Divergent Paths: The 3 Scenarios (Completed) - a redo of the 3 scenarios in the original game that gives equal time to each group. Meant to be a basis for future mods.
FFVI: Divergent Paths (In Progress) - a hack built off of the 3 scenarios that changes other events in the same, such as making Leo permanently recruitable, bringing Banon's story closure, and adding 1 more secret character.
  Find
Quote  

Posts: 131
Threads: 12
Thanks Received: 0
Thanks Given: 13
Joined: Oct 2013
Reputation: 0
Status
None
(01-07-2021, 10:17 PM)PowerPanda Wrote: I think I may have found the problem. You said that you first noticed this after Leo spoke to Lola. When you recruited Leo, did you have:
1. 4 members in your party
2. One of them Mog
3. But not Shadow, Gau, or Gogo?

1 and 3. But I should mention, the order I did things was: Recruited Leo, recruited Mog, fought Tritoch, fought and recruited Umaro, then I did the event with Lola cuz I forgot to do so until then. All these events I had a full party of 4, with the last 3 events having Mog in the party. None of these parties had Shadow, Gau, or Gogo. So I have the feeling it was one of the last 3 events I mentioned, so I feel like it's a problem with either Umaro's recruitment event, or the event with Lola.


If you ever feel useless, just remember that Umaro has an MP stat.
  Find
Quote  

Posts: 383
Threads: 38
Thanks Received: 156
Thanks Given: 97
Joined: Feb 2017
Reputation: 23
Status
None
Huh. I've gone over the Umaro recruitment event, and I can't find any oddities. The Lola event is unchanged, save for checking for Leo instead of Cyan in all relevant spots. I'll check again tomorrow.

For tonight's victory, I fixed the bug with Gau's Father's scene, where it would freeze after Gau learned Fight. The details are too in the weeds for me to go into here though.

I'm hard at work on the Ancient Castle sequence, and have the text rewritten with added event triggers that won't allow you into the caslte unless you have both Leo and Terra in your party.


Projects:
Divergent Paths: The 3 Scenarios (Completed) - a redo of the 3 scenarios in the original game that gives equal time to each group. Meant to be a basis for future mods.
FFVI: Divergent Paths (In Progress) - a hack built off of the 3 scenarios that changes other events in the same, such as making Leo permanently recruitable, bringing Banon's story closure, and adding 1 more secret character.
  Find
Quote  

Posts: 5
Threads: 0
Thanks Received: 0
Thanks Given: 0
Joined: May 2019
Reputation: 0
Status
None
Having a little trouble. I applied the patch with Lunar, but depending on which FF6 rom I use, it either plays a chiming sound over and over again and never starts or a bunch of random colors appear and never starts.

I'm at a loss. Never had this issue before. It may be something I'm doing wrong, but I don't know what. Does the SNES emulator need to be a specific one? The ROM a specific version? Any help would be appreciated.

EDIT: NEVERMIND, I solved it with a utility.
  Find
Quote  

Posts: 1
Threads: 0
Thanks Received: 0
Thanks Given: 0
Joined: Jan 2021
Reputation: 0
Status
None
(01-12-2021, 12:29 AM)nobodyimp Wrote: Having a little trouble. I applied the patch with Lunar, but depending on which FF6 rom I use, it either plays a chiming sound over and over again and never starts or a bunch of random colors appear and never starts.

I'm at a loss. Never had this issue before. It may be something I'm doing wrong, but I don't know what. Does the SNES emulator need to be a specific one? The ROM a specific version? Any help would be appreciated.

EDIT: NEVERMIND, I solved it with a utility.

Hey, could you tell me how you did it? I'm having the same trouble here!
  Find
Quote  



Forum Jump:

Users browsing this thread: 2 Guest(s)


Theme by Madsiur2017Custom Graphics by JamesWhite