Users browsing this thread: 1 Guest(s)
Patch: Replaced Command - Possess with 8 spell list

#21
Posts: 623
Threads: 37
Thanks Received: 44
Thanks Given: 30
Joined: Jan 2015
Reputation: 11
Status
Dead
At one point I had this new command using the Lore animation by default. While it worked a little smoother with alot of monster spells (probably because its ment to cast monster style spells already) it included the litle blue casting effect behind the actor. Maybe desirable for some, just didn't like it as default.

A quick adjustment would be to change the animation pointer entirely, but that would also remove the blue casting effect, so to do it proper I think the adjustment would have to be made at the animation code.

Could probably compare the code for Lore animation at C1/B8E5 and the general casting at C1/ABEB and start swapping values. Haven't looked at either enough to know what to change or attempt to convert half of it without changing all of it. That's where I'd start, other hand that info could be handled out in the great beyond.


The only true wisdom is knowing you know nothing.
  Find
Quote  

#22
Posts: 89
Threads: 2
Thanks Received: 3
Thanks Given: 1
Joined: Jul 2009
Reputation: 5
Status
Vampire
ok so for a non coder I know that i usme would let me change the casting frame. perhaps if i copied red magics specs but changed the glow to blue... still it wouldnt have the unique triangle thingy...

also any non learning magic skill is lore according to program? still I think a casting stance is appropriate
  Find
Quote  

#23
Posts: 335
Threads: 26
Thanks Received: 135
Thanks Given: 125
Joined: Dec 2018
Reputation: 18
Status
Moog
NECROMANCY!

So I've been using this wonderful patch for a while, and the false negative on the command swap was giving me balance problems.
I finally figured out what causes it, though!
$2BAF won't have the right value if someone else is performing an attack when you open the menu!
Since it's a single command parity instead of a series of distinct commands using the Magitek frame work separately, the easiest way to fix the problem is to check a different variable. $64BA is set when at least one party member is in Magitek mode. Since Magitek Mode removes other commands anyway (unless you're doing something REALLY complex), you can safely use this as the flag to check "Hey, is this the Possess Replacer or not" instead of trying to read which menu slot the player's cursor is hovering over.

Just replace the two $2BAF checks with $64BA checks that BEQ when compared to 0 (indicating the Magitek menu should be used instead).
  Find
Quote  



Forum Jump:

Users browsing this thread: 1 Guest(s)


Theme by Madsiur2017Custom Graphics by JamesWhite