FF6 Hacking
RotDS v2.8 download - Printable Version

+- FF6 Hacking (https://www.ff6hacking.com/forums)
+-- Forum: Esper World (https://www.ff6hacking.com/forums/forum-43.html)
+--- Forum: Return of the Dark Sorcerer (https://www.ff6hacking.com/forums/forum-54.html)
+--- Thread: RotDS v2.8 download (/thread-2726.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22


RE: RotDS v2.0.4 download - gameboy2000 - 02-11-2020

When I play this hack, it freezes when I first enter the overworld.


RE: RotDS v2.0.4 download - Gi Nattak - 02-11-2020

Hmm, not sure what to tell you offhand, other than it shouldn't lol. So from a new game, you were able to make it all the way through Fraust/Narshe, and then when exiting the town it freezes? Usually a wrong patching caused by a header issue would have it freeze on the first battle, but if that didn't happen...

Couple usual questions:
1) What emulator are you using?
2) Did you use any of the 'extra' patches the hack comes with, or any other outside patches?
3) Are you sure it's a Final Fantasy III (U) (V1.0) ROM that you're using as a base to patch the hack to?


RE: RotDS v2.0.4 download - gameboy2000 - 02-12-2020

1. Snes9x
2. I didn't use any extra patches.
3. Yes, I am using that version.


RE: RotDS v2.0.4 download - Gi Nattak - 02-12-2020

Very strange, I'm not sure at all. This is the first report of this I've heard thus far, and it's certainly not doing it here on my side.
I'll PM you with a possible 'fix' once I get v2.0.5 out today and we can go from there.


RE: RotDS v2.0.4 download - HoxNorf - 02-12-2020

Is the ROM headered or not?
That might also be a factor, though, don't quote me on that since I never tried it myself.


RE: RotDS v2.0.4 download - gameboy2000 - 02-12-2020

I don't know if it is headered or not. How can I tell?


RE: RotDS v2.0.4 download - Cecil188 - 02-12-2020

A ROM with a header will be 3073 KB in size, and without, it will be 3072 KB in size. You'll need to use the correct patch file between the headered and unheadered ones, but frankly, if the issue is with using the wrong patch file, I'm surprised the game even loaded. I suspect the problem lies elsewhere, but with what, I do not know.


RE: RotDS v2.0.4 download - Ocarina - 02-13-2020

Hello there, my game freezes at a part when Tifa awakes, right at beginning of world of ruins.

I am playing v2.0.4.

I ever did load my 2.0 save just before the burning house freeze on a new v2.0.4 game and it still worked.

Not sure where the problem might be.


RE: RotDS v2.0.4 download - Gi Nattak - 02-13-2020

I'm going to guess that maybe you patched version 2.0.4 over a previous 2.0 version? I'm not positive this is the problem, but when you patch a new version always patch over a clean Final Fantasy III (U) (V1.0) ROM, which is stated in the readme of course. At what point *exactly* is it freezing, like she never is able to get out of bed and the conversation with Oak doesn't happen? I'm going to release version 2.0.5 today, I'll be sure and check it out first to make sure there are no real problems there first. If it continues after the next update and you're doing the patching to a clean ROM correctly, then we'll go from there and I'll ask typical questions like what emulator are you using and if you can provide a save state etc.


RE: RotDS v2.0.4 download - Ocarina - 02-13-2020

Hi, thanks for replying.

To answer your qns:

I patched v2.0.4 over a clean FF iii ROM correctly.

She is able to get out of bed. The game freezes after she says "Oh my God..."

Emulator is SNES9X EX+ 1.5.37 (android mobile, no issues playing v1.8.3 long ago).